[rfc][icedtea-web] localizable Plugin+settings+fix+cleanup
Jacob Wisor
gitne at gmx.de
Sun Sep 14 00:10:39 UTC 2014
On 09/12/2014 at 03:24 PM, Jiri Vanek wrote:
> Hi!
>
> Last of the set. yupii!
>
> Except localizing-able the plugin and settings man/plain/html it celans up
> duplicated strings in NetworkSettingsPanel (and adding soem 7'th featueres)
>
> Tehre is also one change in makefile. I found that i dont like versioned subdirs
> :( SoI created docs/version/normla dirs structure. Especially for man it is
> rmeoving one unnecessary level and do work with it afaikmore comfortable
> diff -r e30d71ab91c6 Makefile.am
> --- a/Makefile.am Wed Sep 10 10:22:46 2014 -0400
> +++ b/Makefile.am Fri Sep 12 15:21:39 2014 +0200
> [...]
> @@ -474,13 +474,13 @@
> endif
>
> stamps/generate-docs.stamp: stamps/netx.stamp
> - mkdir $(DOCS_DIR) ; \
> - HTML_DOCS_TARGET_DIR=$(DOCS_DIR)/html-$(FULL_VERSION) ; \
> - PLAIN_DOCS_TARGET_DIR=$(DOCS_DIR)/plain-$(FULL_VERSION) ; \
> - MAN_DOCS_TARGET_DIR=$(DOCS_DIR)/man-$(FULL_VERSION)/man ; \
> + mkdir -p $(DOCS_DIR) ; \
> + HTML_DOCS_TARGET_DIR=$(DOCS_DIR)/html ; \
> + PLAIN_DOCS_TARGET_DIR=$(DOCS_DIR)/plain ; \
> + MAN_DOCS_TARGET_DIR=$(DOCS_DIR)/man/ ; \
Drop the trailing slash.
> mkdir $$HTML_DOCS_TARGET_DIR ; \
> mkdir $$PLAIN_DOCS_TARGET_DIR ; \
> - mkdir -p $$MAN_DOCS_TARGET_DIR ; \
> + mkdir $$MAN_DOCS_TARGET_DIR ; \
Why did you remove the "-p" switch? It is probably best to have this switch
almost always on in scripts to avoid running into errors just because of
non-existing parent directories.
> [...]
> diff -r e30d71ab91c6 netx/net/sourceforge/jnlp/controlpanel/NetworkSettingsPanel.java
> --- a/netx/net/sourceforge/jnlp/controlpanel/NetworkSettingsPanel.java Wed Sep 10 10:22:46 2014 -0400
> +++ b/netx/net/sourceforge/jnlp/controlpanel/NetworkSettingsPanel.java Fri Sep 12 15:21:39 2014 +0200
> @@ -58,17 +58,17 @@
> @SuppressWarnings("serial")
> public class NetworkSettingsPanel extends JPanel implements ActionListener {
>
> - private DeploymentConfiguration config;
> + private final DeploymentConfiguration config;
>
> private JPanel description;
> - private ArrayList<JPanel> proxyPanels = new ArrayList<JPanel>(); // The stuff with editable fields
> + private final ArrayList<JPanel> proxyPanels = new ArrayList<>(); // The stuff with editable fields
>
> /** List of properties used by this panel */
> - public static String[] properties = { "deployment.proxy.type",
> - "deployment.proxy.http.host",
> - "deployment.proxy.http.port",
> - "deployment.proxy.bypass.local",
> - "deployment.proxy.auto.config.url", };
> + public static String[] properties = { DeploymentConfiguration.KEY_PROXY_TYPE,
> + DeploymentConfiguration.KEY_PROXY_HTTP_HOST,
> + DeploymentConfiguration.KEY_PROXY_HTTP_PORT,
> + DeploymentConfiguration.KEY_PROXY_BYPASS_LOCAL,
> + DeploymentConfiguration.KEY_PROXY_AUTO_CONFIG_URL, };
The formatting here should probably go here like this:
public static String[] properties = {
DeploymentConfiguration.KEY_PROXY_TYPE,
DeploymentConfiguration.KEY_PROXY_HTTP_HOST,
DeploymentConfiguration.KEY_PROXY_HTTP_PORT,
DeploymentConfiguration.KEY_PROXY_BYPASS_LOCAL,
DeploymentConfiguration.KEY_PROXY_AUTO_CONFIG_URL
};
Please also mind the comma after the last element.
> /**
> * Creates a new instance of the network settings panel.
> @@ -259,18 +259,23 @@
> */
> private void setState() {
> ((CardLayout) this.description.getLayout()).show(this.description, config.getProperty(properties[0]));
> - if (config.getProperty(properties[0]).equals("0")) {
> - for (JPanel panel : proxyPanels)
> - enablePanel(panel, false);
> - } else if (config.getProperty(properties[0]).equals("1")) {
> - enablePanel(proxyPanels.get(1), false);
> - enablePanel(proxyPanels.get(0), true);
> - } else if (config.getProperty(properties[0]).equals("2")) {
> - enablePanel(proxyPanels.get(0), false);
> - enablePanel(proxyPanels.get(1), true);
> - } else if (config.getProperty(properties[0]).equals("3")) {
> - for (JPanel panel : proxyPanels)
> - enablePanel(panel, false);
> + switch (config.getProperty(properties[0])) {
> + case "0":
> + for (JPanel panel : proxyPanels)
> + enablePanel(panel, false);
> + break;
> + case "1":
> + enablePanel(proxyPanels.get(1), false);
> + enablePanel(proxyPanels.get(0), true);
> + break;
> + case "2":
> + enablePanel(proxyPanels.get(0), false);
> + enablePanel(proxyPanels.get(1), true);
> + break;
> + case "3":
> + for (JPanel panel : proxyPanels)
> + enablePanel(panel, false);
> + break;
> }
> }
Hmm, although I personally do not like the new switch control structure with
regards to strings, it is much more readable this way. ;-)
> [...]
> diff -r e30d71ab91c6 netx/net/sourceforge/jnlp/resources/Messages.properties
> --- a/netx/net/sourceforge/jnlp/resources/Messages.properties Wed Sep 10 10:22:46 2014 -0400
> +++ b/netx/net/sourceforge/jnlp/resources/Messages.properties Fri Sep 12 15:21:39 2014 +0200
> @@ -876,6 +876,27 @@
> CBCheckSignedAppletDontMatchException = Signed applets are not allowed to run when their actual Codebase does not match the Codebase specified in their manifest. Expected: {0}. Actual: {1}. See: http://docs.oracle.com/javase/7/docs/technotes/guides/jweb/security/no_redeploy.html for details.
> CBCheckSignedFail = Application Codebase does NOT match the Codebase specified in the application's manifest, and this application is signed. You are strongly discouraged from running this application. See: http://docs.oracle.com/javase/7/docs/technotes/guides/jweb/security/no_redeploy.html for details.
>
> +#itweb-settings man (note, spaces (especially the one around @@ markup)are important due to man pages markup
> +ITWSintro= - view and modify settings for @BOLD_OPEN at javaws @BOLD_CLOSE at and the @BOLD_OPEN at browser plugin at BOLD_CLOSE@
What are those "@BOLD_OPEN@" and "@BOLD_CLOSE@" tags? Are they some sort of
project specific markup language? If so, I am very unhappy with this. Where is
the documentation for this? Does it handle @ escapes correctly?
Is "... @BOLD_OPEN at javaws @BOLD_CLOSE at and ..." actually correct?
> +ITWSsynops=command arguments
> +IWSdescL1=is a command line and a GUI program to modify and edit settings used by the icedtea-web implementation \
> +of at BOLD_OPEN@ javaws @BOLD_CLOSE at and the @BOLD_OPEN at browser plugin at BOLD_CLOSE@.
Why did you suddenly introduce broken lines or line continuing characters to
Message.properties, since you have always been strictly against them?
Is "... of at BOLD_OPEN@ javaws @BOLD_CLOSE at and ..." actually correct?
> +IWSdescL2=If executed without any arguments, it starts up a GUI. Otherwise, it tries to do what is specified in the argument.
> +IWSdescL3=The command-line allows quickly searching, making a copy of and modifying specific settings without having to hunt through a UI.
> +IWSexampleL1=Show the GUI editor
> +IWSexampleL2=Resets the value of `{0}` setting.
Are the "`" characters literals in the man page or markups?
> +ITWSdefault=default
> +IWSexampleL3=Known properties
> +IWSexampleL31=(key, value and default value (if different)):
> +IWSexampleL32=(key and default value):
> +
> +#itweb-plugin man (note, spaces (especially the one around @@ markup)are important due to man pages markup
> +ITWPintro=- allow to run @BOLD_OPEN at java applets @BOLD_CLOSE at in your favourite @BOLD_OPEN at browser@BOLD_CLOSE@
Check double spaces.
Is "... run @BOLD_OPEN at java applets @BOLD_CLOSE at in ..." actually correct?
> +ITWPsynopsL1=is working in your browser, once your browser knows about this files.
> +ITWPsynopsL2=The {0} must be placed, or linked iniside specific direcotries. See {1}
Spelling!
> +ITWPsynopsL3=@BOLD_OPEN@ Mozzila compliant browsers @BOLD_CLOSE at like Firefox, Midori, Epiphany, Chrome or Chromium use:
Spelling! The foundation's name is Mozilla!
> +ITWPsynopsL4=@BOLD_OPEN@ Opera family browsers @BOLD_CLOSE at like Opera use:
Please be careful when mentioning registered trademark and product names. If you
mention them, you will probably need to include a statement on their legal
status somewhere in the documentation for certain jurisdictions. Hence, it is
best to avoid them. However, I am also aware that avoiding them completely is
not always possible. Therefore, I strongly suggest to use the term "Mozilla
compatible" only, wherever required. "NPAPI compatible" is also acceptable but
far more technical and probably unknown to most users. "Mozilla compatible"
covers all browsers currently supported by IcedTea-Web and avoids entanglements
with too many entities. Because Mozilla is also the original author of the
NPAPI, it describes the technical aspect sufficiently enough. And, although
Mozilla is trademarked as well, the term would nevertheless reduce any legal
risks to a minimum, especially given the Mozilla foundation's nature and history
in free software. Of course, this does not relieve us of placing a legal notice
in the documentation about Mozilla either, but reduces any efforts to just one
entity.
> [...]
> diff -r e30d71ab91c6 netx/net/sourceforge/jnlp/util/docprovider/ItwebPluginTextProvider.java
> --- a/netx/net/sourceforge/jnlp/util/docprovider/ItwebPluginTextProvider.java Wed Sep 10 10:22:46 2014 -0400
> +++ b/netx/net/sourceforge/jnlp/util/docprovider/ItwebPluginTextProvider.java Fri Sep 12 15:21:39 2014 +0200
> @@ -38,6 +38,7 @@
>
> import java.io.IOException;
> import net.sourceforge.jnlp.config.PathsAndFiles;
> +import net.sourceforge.jnlp.runtime.Translator;
> import net.sourceforge.jnlp.util.docprovider.formatters.formatters.Formatter;
Generally speaking, I am really having trouble accepting this kind of custom
formatter to IcedTea-Web. Actually, this goes for any project which is not
specifically concerned with parsing a well specified language. Unfortunately,
most developers greatly underestimate the prerequisites for a properly working
formatter. The probability of not getting it right is far greater than one would
initially assume. This starts with checking inputs and outputs, goes over
properly handling encoded strings, and ends on handling escapes properly. The
amount of testing required to get /and/ keep a formatter correct is just
enormous. Then, it has to be documented and everybody who wants to add
documentation on a new feature that he/she has just implemented is required to
(a) know how the documentation generator works and (b) understand its formatting.
So ultimately, we should get rid of this formatter and any @TAG@ tags. If you
really need formatting tags for man pages then the documentation generator
should be able to include them itself automatically. Otherwise, adding
documentation becomes unnecessarily difficult and overly complex. It's a pity
that you rushed to push the documentation generator...
Jacob
More information about the distro-pkg-dev
mailing list