[rfc] [icedtea-web] make PAthsAndFilles to follow seted paths
Jie Kang
jkang at redhat.com
Fri Mar 27 20:01:30 UTC 2015
----- Original Message -----
> Hi!
>
> This is first of at least three pathces tro make it work
> this one - i adding difference between getFile/Path and
> getDefaultFile/DefaultPAth + adapting few
> (the most important) PathsAndFiles
> So this one is especially about concept. There rised issue, that
> PathsandFiles become depnding on
> JnlpRuntime.getConfig() - the result of it is later-lazy loading of
> RECENTLY_USED_FILE.
> Also note the behaviour of deployment.user.security.policy
>
> Second part of this work will be focused on adapting missing "adjustable
> files"
> deployment.user.security.trusted.cacerts
> deployment.user.security.trusted.certs
> deployment.user.security.trusted.clientauthcerts
> deployment.user.security.trusted.jssecacerts
> deployment.user.security.trusted.jssecerts
>
> And ensure, that those are never ever used in itw - only the PathsAndFiles
>
> ThirdPart will be then focused on being sure, no dangling insatnces are
> around - taht everything is
> using PAthsAndFiles directly, and so runtime change to any
> InfrastructureFileDescriptor will take
> imidiate effect. (aka changing cache in runtime durng testing)
>
> But this this third part is far faraway...
>
> BAck to this patch:
> I let Defaults.java use CACHE_DIR.getDefaultFullPath() instead of
> CACHE_DIR.getFullPath(). Tahts
> actually very correct - because those are default values. Then I have added
> possibility to override
> getFullPath by get from properties + few small changes for docs generation.
>
> Thoughts?
Hello,
Nice! Review below:
+ this(PathsAndFiles.getRECENTLY_USED_FILE().getFile(), PathsAndFiles.CACHE_DIR.getFile());
Can you explain a little more on why there is a getter for recently used file. Where is the later-lazy loading and what problem is occurring that makes it so you need to have a getter?
Also please don't capitalize words in the function:
s/getRECENTLY_USED_FILE/getRecentlyUsedFile
+ return gcpd(DeploymentConfiguration.KEY_USER_CACHE_DIR);
Please give the function gcpd(...) a descriptive name that gives me an idea of what it's doing without having to look at the function's implementation.
+ //its not recomanded to override default locations methods
s/recomanded/recommended
+ public String getDefaultFullPath() {
return clean(systemPathStub + File.separator + pathStub + File.separator + fileName);
For the function clean(...), can you please either rename it to be more descriptive or add comments to the function. Just seeing the function name I have very little clue as to what it does.
+ private String getStub() {
Can you add comments to this? I don't know what you mean by 'stub'.
Other parts look okay, but please make sure you test this thoroughly. Are there tests for this?
Regards,
>
--
Jie Kang
OpenJDK Team - Software Engineering Intern
More information about the distro-pkg-dev
mailing list