Problem with JVMCI on Cygwin

Russ Powers russpowers at
Thu Mar 2 21:51:05 UTC 2017

Thanks Gilles.  I've tried running in normal Windows command prompt, but it
seems to need sed and find and some other unix utilities, so I tried it
using the git/git bash shell, which did work either.  After digging around
a bit, I noticed it was looking for Cygwin in many places in the build
scripts, referring to a HOTSPOTMKSHOME environment variable (which defaults
to c:\cygwin\bin).  I then tried Cygwin and I got it to fully build and
produce the jvm.dll and whole modified jdk folder (although I had to hack to remove .sha1 checks on downloads, that was causing errors writing
.sha1 files).

Is there something else I should try?

On Thu, Mar 2, 2017 at 5:59 AM, Gilles Duboscq <gilles.m.duboscq at>

> Hi Russ,
> When building on Windows, it's probably better not to use Cygwin.
> When running on cygwin, mx tries to use some kind of hybrid mode where we
> run on cygwin (unix-ish) but target Windows for the JVMCI build. That's
> very fragile/hacky.
> Could you try running in a normal windows environment (make sure you use
> Windows python, not cygwin python)?
> Unfortunately we have not been testing on windows for a long time so it's
> likely that windows support has bit-rotten in both mx and graal-jvmci-8.
>  Gilles
> On 02/03/17 14:33, Russ Powers wrote:
> > Hello,
> >
> > I've managed to build JVMCI on Cygwin, and the
> > jdk1.8.0_121\product\jre\bin\server
> > directory contains the built jvm.dll and jvm.pdb.  However, when I try
> > using mx on graal-core (with the proper JAVA_HOME set), it gives me this
> > error:
> >
> > The VM does not support the minimum JVMCI API version required by Graal.
> > Cannot read JVMCI version from java.vm.version property:
> 25.71-b01-internal.
> > Set the JVMCI_VERSION_CHECK environment variable to "ignore" to suppress
> > this error or to "warn" to emit a warning and continue execution.
> > Currently used Java home directory is c:\proj\graal\tools\graal-
> > jvmci-8\jdk1.8.0_121\product\jre.
> >
> > It looks like the JVMCI info is missing, and when I run ./java -version,
> it
> > doesn't contain the JVMCI info either.  I checked, and it's definitely
> > using the newly built jvm.dll.  Is there something else I should be doing
> > here?  I'm stumped.  Thanks in advance.
> >
> > Russ
> >

More information about the graal-dev mailing list