Error - Cannot read JVMCI version from java.vm.version property

Deepali Patel deepali_patel at
Tue Mar 7 10:07:50 UTC 2017

Yes looks like some issue with the env variable. I do not have a directory called "pathto". I just pasted that instead of putting the path of directory where Graal is present. 
I tried everything all over and it worked. 


-----Original Message-----
From: Doug Simon [mailto:doug.simon at] 
Sent: Tuesday, March 07, 2017 3:18 PM
To: Deepali Patel
Cc: graal-dev at
Subject: Re: Error - Cannot read JVMCI version from java.vm.version property

> On 7 Mar 2017, at 10:06, Deepali Patel <deepali_patel at> wrote:
> Hello,
> I am using a Ubuntu 16.04.2 x86_64 system.
> The java version is:
> openjdk version "1.8.0_121"
> OpenJDK Runtime Environment (build 
> 1.8.0_121-8u121-b13-0ubuntu1.16.04.2-b13)
> OpenJDK 64-Bit Server VM (build 25.121-b13, mixed mode)
> I used the steps in the section to build JVMCI JDK8. The build is successful, the last few lines of output is like:
>                make: Leaving directory '/pathto/Graal/graal-jvmci-8/make'
> Compiling with javac-daemon... [dependency 
> updated] Compiling with 
> javac-daemon... [dependency updated] Compiling 
> with javac-daemon... [dependency 
> updated] Archiving JVMCI_TEST... [dependency 
> updated] Archiving JVM_PRODUCT_SERVER... 
> [dependency hotspot updated] Archiving JVMCI_HOTSPOT... [dependency 
> updated]
> And I update JAVA_HOME using
> export JAVA_HOME=$(mx --java-home /usr/lib/jvm/java-8-openjdk-amd64 
> jdkhome)
> echo $JAVA_HOME shows:
> /pathto/Graal/graal-jvmci-8/jdk1.8.0_121/product
> Next I checkout graal-core and execute mx on it.
> The error seen is:
> The VM does not support the minimum JVMCI API version required by Graal.
> Cannot read JVMCI version from java.vm.version property: 25.121-b13.
> Set the JVMCI_VERSION_CHECK environment variable to "ignore" to suppress this error or to "warn" to emit a warning and continue execution.
> Currently used Java home directory is /usr/lib/jvm/java-8-openjdk-amd64/jre.
> Currently used VM configuration is: OpenJDK 64-Bit Server VM Download 
> the latest JVMCI JDK 8 from 
> ads/index.html
> Please suggest if I have missed out anything here. I do not want to download the built version of JVMCI because in parallel I am working on building it on PPC.

It seems like your $JAVA_HOME env var has a problem otherwise mx should be picking up /pathto/Graal/graal-jvmci-8/jdk1.8.0_121/product not /usr/lib/jvm/java-8-openjdk-amd64/jre. Do you really have a root directory on your system named "pathto"? You can use the --java-home option to mx instead of JAVA_HOME:

mx --java-home /pathto/Graal/graal-jvmci-8/jdk1.8.0_121/product ...


This e-mail may contain privileged and confidential information which is the property of Persistent Systems Ltd. It is intended only for the use of the individual or entity to which it is addressed. If you are not the intended recipient, you are not authorized to read, retain, copy, print, distribute or use this message. If you have received this communication in error, please notify the sender and delete all copies of this message. Persistent Systems Ltd. does not accept any liability for virus infected mails.

More information about the graal-dev mailing list