Request for reviews (XXL): 6893268: additional dynamic language related optimizations in C2
Tom Rodriguez
Thomas.Rodriguez at Sun.COM
Thu Dec 3 10:18:51 PST 2009
ciKlass.cpp: is_in_package isn't really safe since it's not checking for the trailing dot after the package name so it would return true if only the prefix matches. It works fine for your case but it should be correct for all cases. Any reason you're using external_name instead of the symbolOop itself? external_name requires allocation and conversion.
tom
On Dec 2, 2009, at 4:18 AM, Christian Thalinger wrote:
> On Tue, 2009-12-01 at 14:51 -0800, Vladimir Kozlov wrote:
>> src/share/vm/ci/ciExceptionHandler.cpp
>> I think you need to add assert since you removed
>> assert(accessor->get_instanceKlass()->is_linked()) in ciEnv.cpp
>
> Done.
>
>>
>> src/share/vm/runtime/frame.hpp
>> rename is_static to has_receiver in oops_compiled_arguments_do()
>
> Thanks, I missed that one.
>
>>
>> src/share/vm/prims/methodHandleWalk.hpp
>> remove commented lines
>> ! // union {
>> ! jvalue _value;
>> ! Handle _handle;
>> ! // } _value;
>
> Right. Actually I wanted to have some kind of union here, but it does
> not work.
>
> Updated webrev here:
>
> http://cr.openjdk.java.net/~twisti/6893268/webrev.02/
>
> -- Christian
>
More information about the hotspot-compiler-dev
mailing list