review (S) for 6857159: local schedule failed with checkcast of Thread.currentThread()
Tom Rodriguez
Thomas.Rodriguez at Sun.COM
Tue Jul 21 16:03:17 PDT 2009
I changed the name to skip_antidep_check and put in a more extensive
comment.
tom
On Jul 21, 2009, at 2:31 PM, Tom Rodriguez wrote:
>> Can you use is_immutable_load() instead of uses_immutable_memory()
>> since it is load from immutable memory?
>
> That's what I had originally and I changed it since it's technically
> not quite true. The LoadKlass that reads from the cache isn't
> actually reading immutable memory since the cache can be updated,
> though never by generated code. Neither name is really right.
> Maybe it should just be disable_antidep_check with a comment
> explaining why?
>
>> And change comment to include LoadRange:
>>
>> // node matches ideal 'LoadKlassNode' 'LoadNKlassNode'
>>
>> ---
>>
>> // node matches ideal 'LoadKlass' 'LoadNKlass' 'LoadRange'
>
> Ok.
>
> tom
>
>>
>> Thanks,
>> Vladimir
>>
>> Tom Rodriguez wrote:
>>> http://cr.openjdk.java.net/~never/6857159
>
More information about the hotspot-compiler-dev
mailing list