RFR (XL): 7172640: C2: instrinsic implementations in LibraryCallKit should use argument() instead of pop()
John Rose
john.r.rose at oracle.com
Mon Nov 26 22:21:15 PST 2012
Reviewed; ship it. Some comments:
The cleanups with Bytecodes::has_receiver and arg_size_for_bc are very good too.
I like your renamings: It feels much more rational and regular.
The for_parse argument to GraphKit::compute_stack_effects is dead now; you may delete it.
I suggest removing "_as" in null_check_receiver_as_before_call; it feels like a "noise word"[1].
We are not in the habit of using "(void)" casts. I think it would require an astronomically high warning level to benefit from them.
These are all suggestions. In any case, ship it!
— John
[1] https://wikis.oracle.com/display/HotSpotInternals/StyleGuide#StyleGuide-Naming
On Nov 21, 2012, at 5:02 PM, Christian Thalinger wrote:
> On Nov 21, 2012, at 3:56 PM, John Rose <john.r.rose at oracle.com> wrote:
>
>> On Nov 20, 2012, at 6:47 PM, Christian Thalinger wrote:
>>
>>> http://cr.openjdk.java.net/~twisti/7172640
>>
>> That's a lovely cleanup...
>
> webrev is updated.
More information about the hotspot-compiler-dev
mailing list