Request for Review: JDK-8006938: Change os::print_location to be more descriptive when a location is pointing into an object

Christian Thalinger christian.thalinger at oracle.com
Tue Feb 19 15:52:39 PST 2013


On Feb 18, 2013, at 10:07 PM, Poonam Bajaj <poonam.bajaj at oracle.com> wrote:

> Hello Chris,
> 
> Thanks for the review.
> 
> Yes, this code is more clear and understandable. But this fix is a backport of https://jbs.oracle.com/bugs/browse/JDK-8000230 which is already in hsx25. Changeset in hsx25:
> http://hg.openjdk.java.net/hsx/hotspot-gc/hotspot/rev/85f1cded9793
> 
> This webrev is for hsx24. So I don't think we should have a different fix from hsx25.

And I reviewed it the last time as well:

8000230: Change os::print_location to be more descriptive when a location is pointing into an object
Reviewed-by: mgerdin, twisti

so I can't argue with the fix now, can I?  ;-)  The change looks good then for HS24.

-- Chris

> 
> Thanks,
> Poonam
> 
> On 2/19/2013 2:09 AM, Christian Thalinger wrote:
>> On Feb 17, 2013, at 6:59 PM, Poonam Bajaj<poonam.bajaj at oracle.com>  wrote:
>> 
>>> Could I have couple of reviews for this small change.
>>> 
>>> Webrev: http://cr.openjdk.java.net/~poonam/8006938/webrev.00/
>> +      if (p == (HeapWord*) addr) {
>> 
>> This compare is hard to follow.  Can't we move the printing into this code, like:
>> 
>>  886     if (p != NULL&&  Universe::heap()->block_is_obj(p)) {
>>  896         st->print_cr(INTPTR_FORMAT " is pointing into object: " INTPTR_FORMAT, addr, p);
>>  887       print = true;
>>  888     } else if (p == NULL&&  ((oopDesc*)addr)->is_oop()) {
>>  894         st->print_cr(INTPTR_FORMAT " is an oop", addr);
>>  889       p = (HeapWord*) addr;
>>  890       print = true;
>>  891     }
>> 
>> -- Chris
>> 
>>> CR: https://jbs.oracle.com/bugs/browse/JDK-8006938
>>> 
>>> Change in os::print_location() to print more descriptive information about objects.
>>> 
>>> Thanks,
>>> Poonam
>>> 
>>> 



More information about the hotspot-compiler-dev mailing list