RFR(M): 6700100: optimize inline_native_clone() for small objects with exact klass

Aleksey Shipilev aleksey.shipilev at oracle.com
Tue Oct 28 09:53:40 UTC 2014


On 10/28/2014 12:18 PM, Roland Westrelin wrote:
> Anyone else for this review?
> 
> Roland.
> 
> 
>> On Oct 23, 2014, at 1:50 PM, Roland Westrelin <roland.westrelin at oracle.com> wrote:
>>
>> Vladimir,
>>
>> Here is a new webrev that takes your comments into account:
>>
>> http://cr.openjdk.java.net/~roland/6700100/webrev.01/

No red flags from me.

A minor pet peeve about the code style in Hotspot, which adds up to
accidental code complexity: pro-actively blowing up more methods than
required to solve the task at hand.

This change provides the example: both compute_injected_fields() and
has_injected_fields() do dances around _has_injected_fields value. It
would seem more readable to just have has_injected_fields() to lazily
compute the value on demand, inlining both compute_injected_fields() and
compute_injected_fields_helper(). That would spare two additional
methods, and make the code generally more readable, and maintainable.

Thanks,
-Aleksey.





-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <http://mail.openjdk.java.net/pipermail/hotspot-compiler-dev/attachments/20141028/14bcdfd9/signature.asc>


More information about the hotspot-compiler-dev mailing list