[9] RFR(S): 8066312: Add new Node* Node::find_user(int opc) method
Vladimir Kozlov
vladimir.kozlov at oracle.com
Fri Jan 16 20:49:19 UTC 2015
Good.
Thanks,
Vladimir
On 1/16/15 12:34 PM, Zoltán Majó wrote:
> Hi,
>
>
> On 01/15/2015 07:14 PM, Vladimir Kozlov wrote:
>> New web is good.
>
> could you please take another look at this issue? The previous webrev,
> webrev.02 broke the product build because the methods
>
> has_out(int upcode) and has_out(DUIterator i)
>
> are ambiguous to GCC in the product build. (When working on webrev.02, I
> considered that changing a method's name is a minor change, so I tested
> only locally with fastdebug.)
>
> Now I renamed
>
> has_out(int opcode) -> has_out_with(int opcode)
> find_out(int opcode) -> find_out_with(int opcode)
>
> I renamed both methods so that the naming stays consistent among them.
>
> JPRT tests pass on all platforms.
>
> Here is the new webrev:
> http://cr.openjdk.java.net/~zmajo/8066312/webrev.03/
>
> Sorry for the extra work.
>
> Thank you and best regards,
>
>
> Zoltan
>
>>
>> Thanks,
>> Vladimir
>>
>> On 1/15/15 2:58 AM, Zoltán Majó wrote:
>>> Hi John,
>>>
>>>
>>> thank you for the review!
>>>
>>> On 01/14/2015 01:12 AM, John Rose wrote:
>>>> Good.
>>>>
>>>> One suggestion: Call it "find_out", not "find_user". The term "out"
>>>> is more in use for Node than "user"; cf. Node::unique_out, raw_out.
>>>
>>> I changed the names of the methods, as you suggested. Here is the
>>> updated webrev:
>>>
>>> http://cr.openjdk.java.net/~zmajo/8066312/webrev.02/
>>>
>>> Thank you and best regards,
>>>
>>>
>>> Zoltan
>>>
>>>>
>>>> — John
>>>>
>>>> On Jan 13, 2015, at 3:41 AM, Zoltán Majó <zoltan.majo at oracle.com>
>>>> wrote:
>>>>> Hi,
>>>>>
>>>>>
>>>>> please review the following small patch.
>>>>>
>>>>> Bug: https://bugs.openjdk.java.net/browse/JDK-8066312
>>>>>
>>>>> Problem: There are some locations in the source code that search for
>>>>> users of a node of a particular type.
>>>>>
>>>>> Solution: To simplify the code, this patch adds a new method,
>>>>> Node::find_user(int opc) that can be used for searching. This patch
>>>>> also updates some comments in the source code.
>>>>>
>>>>> Webrev: http://cr.openjdk.java.net/~zmajo/8066312/webrev.00/
>>>>>
>>>>> Testing: JPRT
>>>>>
>>>>> Thank you and best regards,
>>>>>
>>>>>
>>>>> Zoltan
>>>>>
>>>
>
More information about the hotspot-compiler-dev
mailing list