RFR: 8146416: java.lang.OutOfMemoryError triggers: assert(current_bci == 0) failed: bci isn't zero for do_not_unlock_if_synchronized

Jamsheed C m jamsheed.c.m at oracle.com
Wed Jun 1 11:33:16 UTC 2016


Hi Roland, and All,

earlier implementation was not correct!

i have updated the patch in place.

Please review.

Best Regards,

Jamsheed


On 5/31/2016 4:36 PM, Jamsheed C m wrote:
> Hi Roland, and All,
>
> I have made shared only change.
>
> Revised webrev: http://cr.openjdk.java.net/~jcm/8146416/webrev.01/
>
> Best Regards,
>
> Jamsheed
>
>
> On 5/27/2016 7:56 PM, Jamsheed C m wrote:
>> some of the code that may require change
>>
>> this is based on quick grep result.. not based on analysis
>>
>> ...
>>   guarantee(!(thread->deopt_nmethod()->is_compiled_by_c2() &&
>>               *bcp == Bytecodes::_monitorenter &&
>>               exec_mode == Deoptimization::Unpack_exception),
>>             "shouldn't get exception during monitorenter");
>>
>> ...
>>     } else if (JvmtiExport::can_force_early_return() && state != NULL 
>> && state->is_earlyret_pending()) {
>>
>> ...
>>
>>     (is_top_frame && (exec_mode == Unpack_exception) && 
>> iframe->interpreter_frame_expression_stack_size() == 0) ||
>>
>>
>> Best Regards,
>> Jamsheed
>> On 5/27/2016 2:52 PM, Jamsheed C m wrote:
>>> My concern is like adding  checks in shared code, would reduce 
>>> readability still further..
>>>
>>> for platform change its simple check and forward change, a detailed 
>>> comment would do!
>>>
>>> Best Regards,
>>> Jamsheed
>>>
>>> On 5/27/2016 1:13 PM, Roland Westrelin wrote:
>>>> Hi Jamsheed,
>>>>
>>>>> can i go ahead with this change ?
>>>> I still think a shared code only change would be better (unless you
>>>> demonstrate a reasonable shared code change is not possible). What do
>>>> others think?
>>>>
>>>> Roland.
>>>
>>
>



More information about the hotspot-compiler-dev mailing list