RFR: JDK-8180487: HotSpotResolvedJavaMethod#setNotInlineable() should be renamed to represent actual behavior

Doug Simon doug.simon at oracle.com
Thu May 18 09:11:10 UTC 2017


The code changes look good. However, the javadoc still describes the functionality as a query:

     /**
      * Determines if {@code method} should not be inlined or compiled.
      */

where as it's really a setter. That is, the comment should be:

     /**
      * Sets flags on {@code method} indicating that it should never be inlined or compiled by the VM.
      */

-Doug

> On 18 May 2017, at 05:18, Yasumasa Suenaga <yasuenag at gmail.com> wrote:
> 
> Hi all,
> 
> This review request is related to [1].
> 
> JBS: https://bugs.openjdk.java.net/browse/JDK-8180487
> Patch: http://cr.openjdk.java.net/~ysuenaga/JDK-8180487/webrev.00/
> 
> Could you review it?
> 
> I cannot access JPRT.
> So I need a sponsor.
> 
> 
> Thanks,
> 
> Yasumasa
> 
> 
> [1] http://mail.openjdk.java.net/pipermail/hotspot-compiler-dev/2017-May/026218.html



More information about the hotspot-compiler-dev mailing list