RFR: 8209186: Rename SimpleThresholdPolicy to TieredThresholdPolicy
Per Liden
per.liden at oracle.com
Thu Aug 9 13:43:46 UTC 2018
Hi Claes,
On 08/09/2018 12:38 PM, Claes Redestad wrote:
> Hi,
>
> Nils recently reminded me that we should rename the
> SimpleThresholdPolicy following the merge with AdvancedThresholdPolicy[0].
>
> Webrev: http://cr.openjdk.java.net/~redestad/8209186/open.00/
The include order in compilationPolicy.cpp is now slightly incorrect:
...
37 #include "runtime/frame.hpp"
38 #include "runtime/handles.inline.hpp"
39 #include "runtime/rframe.hpp"
40 #include "runtime/tieredThresholdPolicy.hpp" <------------
41 #include "runtime/stubRoutines.hpp"
42 #include "runtime/thread.hpp"
43 #include "runtime/timer.hpp"
44 #include "runtime/vframe.hpp"
...
cheers,
Per
>
> Bug: https://bugs.openjdk.java.net/browse/JDK-8209186
>
> While this is mostly a straightforward rename, I also took the liberty
> of inlining simpleThresholdPolicy.inline.hpp into
> tieredThresholdPolicy.cpp (it was previously shared between simple- and
> advancedThresholdPolicy.cpp).
>
> Thanks!
>
> /Claes
>
> [0] https://bugs.openjdk.java.net/browse/JDK-8202711
>
More information about the hotspot-compiler-dev
mailing list