RFR: 8209186: Rename SimpleThresholdPolicy to TieredThresholdPolicy

Claes Redestad claes.redestad at oracle.com
Thu Aug 9 18:24:31 UTC 2018


On 2018-08-09 17:47, Vladimir Kozlov wrote:
> This looks good.

Thanks!

>
> Please, add testing link into bug report.

Done.

/Claes

>
> Thanks,
> Vladimir
>
> On 8/9/18 3:38 AM, Claes Redestad wrote:
>> Hi,
>>
>> Nils recently reminded me that we should rename the 
>> SimpleThresholdPolicy following the merge with 
>> AdvancedThresholdPolicy[0].
>>
>> Webrev: http://cr.openjdk.java.net/~redestad/8209186/open.00/
>>
>> Bug: https://bugs.openjdk.java.net/browse/JDK-8209186
>>
>> While this is mostly a straightforward rename, I also took the 
>> liberty of inlining simpleThresholdPolicy.inline.hpp into 
>> tieredThresholdPolicy.cpp (it was previously shared between simple- 
>> and advancedThresholdPolicy.cpp).
>>
>> Thanks!
>>
>> /Claes
>>
>> [0] https://bugs.openjdk.java.net/browse/JDK-8202711
>>



More information about the hotspot-compiler-dev mailing list