RFR (XS) 8206931: Misleading "COMPILE SKIPPED: invalid non-klass dependency" compile log

Tom Rodriguez tom.rodriguez at oracle.com
Tue Jul 10 15:41:39 UTC 2018



Aleksey Shipilev wrote on 7/10/18 5:04 AM:
> On 07/10/2018 01:19 PM, Vladimir Ivanov wrote:
>> src/hotspot/share/ci/ciEnv.cpp:
>>
>> IMO the code is more readable when the check is left as is, but the messages are swapped instead:
>>
>>       } else if (Dependencies::is_klass_type(result)) {
>>         record_failure("concurrent class loading");
>>       } else {
>>         record_failure("invalid non-klass dependency");
>>       }
> 
> That makes sense:
>   http://cr.openjdk.java.net/~shade/8206931/webrev.02/

Swapping the messages looks better.

You shouldn't change the logic in jvmciEnv.cpp.  It's actually correct. 
!is_klass_type(result) basically means result == call_site_target_value 
and since that dependence doesn't trigger a counter change we just want 
to report a failure instead of reporting it as invalid.

tom

> 
> -Aleksey
> 


More information about the hotspot-compiler-dev mailing list