RFR(S): 8223140: Clean-up in 'ok_to_convert()'.
Vladimir Ivanov
vladimir.x.ivanov at oracle.com
Tue Apr 30 16:54:36 UTC 2019
Looks good.
I like precond/postcond macros.
+static bool is_cloop_increment(Node* inc) {
+ precond(inc->Opcode() == Op_AddI || inc->Opcode() == Op_AddL);
Best regards,
Vladimir Ivanov
On 30/04/2019 07:11, Patric Hedlin wrote:
> Dear all,
>
> I would like to ask for help to review the following change/update:
>
> Issue: https://bugs.openjdk.java.net/browse/JDK-8223140
> Webrev: http://cr.openjdk.java.net/~phedlin/tr8223140/
>
> 8223140: Clean-up in 'ok_to_convert()'
>
> Simplify logic in 'ok_to_convert()'.
> Rename 'is_loop_iv()' to 'is_cloop_ind_var()'.
> Adding precond/postcond macros.
>
>
> Testing: Part of 8216137 (hs-tier1..4, hs-precheckin-comp, Kitchensink24h)
>
>
> Best regards,
> Patric
>
More information about the hotspot-compiler-dev
mailing list