[13]RFR: 8226627: assert(t->singleton()) failed: must be a constant
Pengfei Li (Arm Technology China)
Pengfei.Li at arm.com
Tue Jul 2 09:59:15 UTC 2019
Hi Jamsheed,
> > webrev: http://cr.openjdk.java.net/~jcm/8226627/webrev.00/
I see a clever implementation of using "jint_cast" and "jlong_cast" in "add_ring()" to handle +0.0/-0.0. We previously defined very similar functions "pos_finf" and "pos_dinf" [1] which are used in add_id(). Is it possible to replace these two methods to jfloat_cast and jdouble_cast and remove the duplicate code?
Another nit: Please remove the trailing space in line " if (f0 != 0.0f || f1 != 0.0f) { ".
[1] http://hg.openjdk.java.net/jdk/jdk/file/5ce081828739/src/hotspot/share/opto/type.cpp#l456
--
Thanks,
Pengfei
More information about the hotspot-compiler-dev
mailing list