RFR(S): 8233193: Incorrect bailout from possibly_add_compiler_threads
Tobias Hartmann
tobias.hartmann at oracle.com
Mon Nov 18 14:58:13 UTC 2019
Hi Martin,
this looks good to me.
Best regards,
Tobias
On 14.11.19 17:18, Doerr, Martin wrote:
> Hi,
>
> I'd like to cleanup exception handling in CompileBroker a little bit.
>
> Here's my proposal:
> - Use THREAD instead of CHECK where no exceptions get thrown.
> - Remove unused preload_classes.
> - make_thread: Rename thread to new_thread to avoid confusion with THREAD (the current compiler thread).
> - possibly_add_compiler_threads: Remove usage of EXCEPTION_MARK + CHECK because this functions is not supposed to kill the VM on exceptions. Add assertion to caller.
>
> Webrev:
> http://cr.openjdk.java.net/~mdoerr/8233193_CompileBroker/webrev.00/
>
> @David:
> You didn't like usage of the CHECK macro in the initialization functions, but I think they are ok.
> Not very nice to read, but the behavior looks ok to me.
> At least, I didn't find a better replacement for them. Maybe you have a proposal?
>
> Best regards,
> Martin
>
More information about the hotspot-compiler-dev
mailing list