RFR(M): 8067651: Fix Trivial code path for LevelTransitionTest.java
Igor Ignatyev
igor.ignatyev at oracle.com
Fri Jul 31 17:11:39 UTC 2020
Hi Evgeny,
in general looks good to me, a couple comments/questions though:
- I don't see necessity of move Helper.* methods into the enclosing class, nor do I see it as improving readability of the test. why did you decide to move them?
- if the test is inapplicable for Xcomp run, you should either throw SkippedException instead of System.err::println at L#67 or use '@requires vm.compMode != "Xcomp"' in jtreg test description. currently, the former provides arguable more clear message that the test wasn't run (as it sets special sub-status which is understood by our test execution system) than the latter (which will just omit test from test results altogether), however @requires is "faster" as jtreg don't need to run any of the test code. in any case, both makes it clean that the test wasn't really performed, while your code will lead to a passed-passed test w/o no automated way to know that the test wasn't run.
- from you explanation of the fix it's also unclear why BackgroundCompilation got disabled, could you please explain?
Thanks,
-- Igor
> On Jul 27, 2020, at 12:38 PM, Evgeny Nikitin <evgeny.nikitin at oracle.com> wrote:
>
> Hi,
>
> Bug: https://bugs.openjdk.java.net/browse/JDK-8067651
> Webrev: https://cr.openjdk.java.net/~enikitin/8067651/webrev.00/
>
> Adjusting the test to current state of the VM.
>
> - Definition of 'trivial code' does not depend on whether the method has been profiled or not;
> - Trivial code does only go level 0 to level 1;
> - Some refactoring.
>
> The change has been checked in mach5 for the 5 platforms (passed).
>
> Please review,
> /Evgeny Nikitin.
More information about the hotspot-compiler-dev
mailing list