RFR: 8251994: VM crashed running TestComplexAddrExpr.java test with -XX:UseAVX=X

Claes Redestad redestad at openjdk.java.net
Mon Oct 26 16:10:19 UTC 2020


On Mon, 26 Oct 2020 15:57:43 GMT, Aleksey Shipilev <shade at openjdk.org> wrote:

>>> Drive-by comment:
>>> 
>>> * synopsis should be "crashed", not "crushed"?
>> 
>> Fixed.
>> 
>>> * I personally find `VECTOR_LOOP_SIMD` more fragile than the `_do_vector_loop_experimental` field. At least the macro should also say "experimental"?
>> 
>> 'fragile' is in naming sense to use `DO_VECTOR_LOOP_EXPERIMENTAL`, for example?
>> Or you prefer to have the code be guarded by `if(_do_vector_loop_experimental)` runtime check instead of `#if DO_VECTOR_LOOP_EXPERIMENTAL` macro check?
>
>> 'fragile' is in naming sense to use `DO_VECTOR_LOOP_EXPERIMENTAL`, for example?
> 
> This makes most sense, I believe.
> 
>> Or you prefer to have the code be guarded by `if(_do_vector_loop_experimental)` runtime check instead of `#if DO_VECTOR_LOOP_EXPERIMENTAL` macro check?
> 
> Yeah, I am not a big fan of doing macros when runtime checks carry the same weight. I understand you want to micro-optimize these paths with macros, but I think the runtime checks work without much penalty here? I would defer to compiler reviewers to say which one is better.

Wouldn't something like a `const bool _do_vector_loop_experimental = false;` eliminate the disabled code anyway?

-------------

PR: https://git.openjdk.java.net/jdk/pull/859


More information about the hotspot-compiler-dev mailing list