[jdk18] RFR: 8278889: AArch64: [vectorapi] VectorMaskLoadStoreTest.testMaskCast() test fail [v2]

Eric Liu eliu at openjdk.java.net
Wed Dec 22 01:06:20 UTC 2021


On Tue, 21 Dec 2021 18:17:30 GMT, Dean Long <dlong at openjdk.org> wrote:

>> Eric Liu has updated the pull request incrementally with one additional commit since the last revision:
>> 
>>   small fix
>>   
>>   Change-Id: Id71ebe5161fac08a689ee3ec538b485f6c172186
>
> src/hotspot/cpu/aarch64/c2_MacroAssembler_aarch64.cpp line 1264:
> 
>> 1262:       break;
>> 1263:     case 256:
>> 1264:       sve_ptrue(dst, size, /* VL256 */ 0b01101);
> 
> Why not use an enum for these magic constants?

I think these magic numbers are only used by sve_ptrue and probably there should be no one need to write these magic numbers again. If these magic numbers are really common used,  I agree with yours that enum is better.

-------------

PR: https://git.openjdk.java.net/jdk18/pull/49


More information about the hotspot-compiler-dev mailing list