RFR: 8261336: IGV: enhance default filters [v2]
Roberto Castañeda Lozano
rcastanedalo at openjdk.java.net
Mon Feb 15 11:15:12 UTC 2021
On Fri, 12 Feb 2021 12:14:53 GMT, Christian Hagedorn <chagedorn at openjdk.org> wrote:
>> Roberto Castañeda Lozano has updated the pull request incrementally with five additional commits since the last revision:
>>
>> - Rewrite 'Show control flow only' filter using categories
>> - Add leading underscore field
>> - Move assertion to a default switch case
>> - Indent switch statements
>> - Use a scoped enum for type categories (as per the HotSpot style guide)
>
> src/hotspot/share/opto/idealGraphPrinter.hpp line 95:
>
>> 93: bool _traverse_outs;
>> 94: Compile *C;
>> 95: double max_freq;
>
> Fields should have a leading underscore.
Done.
> src/hotspot/share/opto/type.cpp line 1120:
>
>> 1118: Type::CATEGORY Type::category() const {
>> 1119: const TypeTuple* tuple;
>> 1120: switch (base()) {
>
> Might be more readable if switch cases are indented.
Done.
-------------
PR: https://git.openjdk.java.net/jdk/pull/2499
More information about the hotspot-compiler-dev
mailing list