[jdk16] RFR: 8260608: add a regression test for 8260370
Vladimir Kozlov
kvn at openjdk.java.net
Thu Jan 28 23:04:46 UTC 2021
On Thu, 28 Jan 2021 22:11:02 GMT, Igor Ignatyev <iignatyev at openjdk.org> wrote:
>> test/hotspot/jtreg/compiler/loopopts/TestLoopLimitNodeElimination.java line 42:
>>
>>> 40: long b[] = new long[a];
>>> 41:
>>> 42: void c(String[] d) {
>>
>> Please, don't use single latter for constants and method names. It is better to not use them for anything - all names should be meaningful.
>>
>> Also you need to change RFE to Bug. the process only allows test bugs:
>> http://openjdk.java.net/jeps/3#rdp-2
>> `RDP2: P1–P5 doc/test bugs`
>
> Vladimir, there is nothing meaningful about these constants, methods, variables — the whole test is randomly generated.
Got it. But even then, you can at least rename 'c()' to 'test()' and 'a' to 'N'. And add comment that it is randomly generated to avoid complains later.
-------------
PR: https://git.openjdk.java.net/jdk16/pull/137
More information about the hotspot-compiler-dev
mailing list