RFR: 8267956: C1 code cleanup

Tobias Hartmann thartmann at openjdk.java.net
Mon Jul 5 09:47:48 UTC 2021


On Wed, 16 Jun 2021 09:05:45 GMT, Yi Yang <yyang at openjdk.org> wrote:

> While skimming C1 code, I found a lot of useless/invalid/unimplemented code, they can be harmless removed.
> 
> - Unused IntInterval in type hierarchy
> - Unused MethodDataConstant in type hierarchy
> - Unused MethodDataType in type hierarchy
> - Unused LIRGenerator::maybe_mask_boolean after JDK-XXX...
> - Unused is_*_stub() **virtual methods** in CodeStub
> - Unused start_block and bind_block_entry declarations in c1_LIRGenerator.hpp
> - Residual do_ClassIDIntrinsic declarations in c1_LIRGenerator.hpp
> - Meet/join are never implemented
> - LIRTracePeephole does nothing, also its name is confusing
> - Directly define inline functions in c1_ValueSet.hpp and remove c1_ValueSet.inline.hpp and c1_ValueSet.cpp files
> - Duplicated Compilation::count_invocations() and Compilation::count_backedges()
> - Remove c1_Defs.cpp
> - Remove lir_backwardbranch_target
> 
> Thanks!

Nice cleanup. Looks good to me.

-------------

Marked as reviewed by thartmann (Reviewer).

PR: https://git.openjdk.java.net/jdk/pull/4508


More information about the hotspot-compiler-dev mailing list