Integrated: 8267956: C1 code cleanup
Yi Yang
yyang at openjdk.java.net
Tue Jul 6 02:15:58 UTC 2021
On Wed, 16 Jun 2021 09:05:45 GMT, Yi Yang <yyang at openjdk.org> wrote:
> While skimming C1 code, I found a lot of useless/invalid/unimplemented code, they can be harmless removed.
>
> - Unused IntInterval in type hierarchy
> - Unused MethodDataConstant in type hierarchy
> - Unused MethodDataType in type hierarchy
> - Unused LIRGenerator::maybe_mask_boolean after JDK-XXX...
> - Unused is_*_stub() **virtual methods** in CodeStub
> - Unused start_block and bind_block_entry declarations in c1_LIRGenerator.hpp
> - Residual do_ClassIDIntrinsic declarations in c1_LIRGenerator.hpp
> - Meet/join are never implemented
> - LIRTracePeephole does nothing, also its name is confusing
> - Directly define inline functions in c1_ValueSet.hpp and remove c1_ValueSet.inline.hpp and c1_ValueSet.cpp files
> - Duplicated Compilation::count_invocations() and Compilation::count_backedges()
> - Remove c1_Defs.cpp
> - Remove lir_backwardbranch_target
>
> Thanks!
This pull request has now been integrated.
Changeset: 29267698
Author: Yi Yang <yyang at openjdk.org>
URL: https://git.openjdk.java.net/jdk/commit/2926769800de8610a824d8f8bf9ea3e2a4417164
Stats: 241 lines in 18 files changed: 5 ins; 217 del; 19 mod
8267956: C1 code cleanup
Reviewed-by: thartmann
-------------
PR: https://git.openjdk.java.net/jdk/pull/4508
More information about the hotspot-compiler-dev
mailing list