RFR: 8238812: assert(false) failed: bad AD file [v2]
Christian Hagedorn
chagedorn at openjdk.java.net
Thu Mar 4 09:22:55 UTC 2021
On Wed, 3 Mar 2021 10:55:07 GMT, Rahul Raghavan <rraghavan at openjdk.org> wrote:
>> src/hotspot/share/opto/ifnode.cpp line 723:
>>
>>> 721:
>>> 722: // Is the comparison for this If suitable for folding?
>>> 723: bool IfNode::cmpi_folds(PhaseIterGVN* igvn) {
>>
>> We should probably rename it into `cmp_folds` now that it is also for unsigned and also update the description above. Shouldn't the description be at `fold_compares()` anyways? But maybe we want to clean this up in a follow-up RFE.
>
> Yes, will rename `cmpi_folds` to `cmp_folds`.
>
> Not changing the fold compares description location for now.
> For now maybe it is okay location for description as that is starting of fold_compares implementation (all methods above fold_compares definition seems mainly its helper functions)
> .e.g.: See the comment and declarations in [cfgnode.hpp]
> ........
> private:
> // Helper methods for fold_compares
> bool cmp_folds(PhaseIterGVN* igvn);
> bool is_ctrl_folds(Node* ctrl, PhaseIterGVN* igvn);
> Or yes agree we can change this in a follow-up RFE.
Yeah, it's probably best to leave it as it is at the moment and clean it up later in an RFE.
-------------
PR: https://git.openjdk.java.net/jdk/pull/2758
More information about the hotspot-compiler-dev
mailing list