RFR: 8265129: Add intrinsic support for JVM.getClassId [v10]
Markus Grönlund
mgronlun at openjdk.java.net
Fri May 21 11:55:35 UTC 2021
On Fri, 21 May 2021 11:39:50 GMT, Markus Grönlund <mgronlun at openjdk.org> wrote:
>> Denghui Dong has updated the pull request incrementally with one additional commit since the last revision:
>>
>> update
>
> src/hotspot/share/jfr/jfr.hpp line 59:
>
>> 57:
>> 58: // get_class_id intrinsic support
>> 59: static void trace_id_load_barrier(Klass* klass);
>
> I think we can make this general, because it is not necessarily specialized for the intrinsic use. Can we rename this to "get_class_id(const Klass* klass): instead? Then we can remove the comment // get_class_id intrinsic support., thanks
Hmm, perhaps that was not such a good idea after all - it would require that you have tested for tagging at the call site. But "get_class_id_intrinsic(const Klass* klass):" might perhaps be ok.
-------------
PR: https://git.openjdk.java.net/jdk/pull/3470
More information about the hotspot-compiler-dev
mailing list