RFR: 8277042: add test for 8276036 to compiler/codecache

Christian Hagedorn chagedorn at openjdk.java.net
Fri Nov 12 13:59:36 UTC 2021


On Fri, 12 Nov 2021 08:54:57 GMT, Takuya Kiriyama <duke at openjdk.java.net> wrote:

> Could you please review the 8277042 code?  
> This is the enhancement for 8276036.  
> I add a new test to verify the value of full_count in the message of insufficient codecache.

Otherwise, looks good! Thanks for adding this test.

test/hotspot/jtreg/compiler/codecache/CodeCacheFullCountTest.java line 56:

> 54:     }
> 55: 
> 56:     public static void runtest() throws Throwable {

Should be CamelCase: `runTest()`.

test/hotspot/jtreg/compiler/codecache/CodeCacheFullCountTest.java line 71:

> 69:             }
> 70:         } else {
> 71:             throw new RuntimeException("codecache shortage was not occured.");

`was not occured` -> `did not occur`

test/hotspot/jtreg/compiler/codecache/CodeCacheFullCountTest.java line 97:

> 95: abstract class Foo {
> 96:     public abstract int foo();
> 97: }

Add some spaces between the classes to improve the readability.

-------------

Marked as reviewed by chagedorn (Reviewer).

PR: https://git.openjdk.java.net/jdk/pull/6364


More information about the hotspot-compiler-dev mailing list