RFR: JDK-8277139 Improve code readability in PredecessorValidator (c1_IR.cpp) [v3]
Ludvig Janiuk
duke at openjdk.java.net
Thu Nov 25 08:09:04 UTC 2021
On Wed, 24 Nov 2021 16:41:35 GMT, Christian Hagedorn <chagedorn at openjdk.org> wrote:
>> Ludvig Janiuk has updated the pull request incrementally with two additional commits since the last revision:
>>
>> - last one now
>> - more asterisks ;)
>
> src/hotspot/share/c1/c1_IR.cpp line 1308:
>
>> 1306: }
>> 1307: for (int i = 0; i < block->number_of_exception_handlers(); i++) {
>> 1308: assert(block->exception_handler_at(i)->is_set(BlockBegin::exception_entry_flag), "must be xhandler");
>
> Could these two assertions also directly be moved before the `collect_predecessor()` calls below?
I've split these loops up on purpose because I want to separate concerns. I appreciate the urge to optimize for fewer iterations, but I think the added readability will enable other, bigger optimizations.
-------------
PR: https://git.openjdk.java.net/jdk/pull/6394
More information about the hotspot-compiler-dev
mailing list