RFR: 8259609: C2: optimize long range checks in long counted loops [v12]

Roland Westrelin roland at openjdk.java.net
Tue Oct 26 13:33:19 UTC 2021


On Mon, 25 Oct 2021 12:32:44 GMT, Roland Westrelin <roland at openjdk.org> wrote:

>> src/hotspot/share/opto/loopnode.hpp line 1657:
>> 
>>> 1655:   void try_sink_out_of_loop(Node* n);
>>> 1656: 
>>> 1657:   Node* clamp(Node* pNode, Node* pNode1, Node* pNode2);
>> 
>> Argument naming is not consistent with the implementation.
>
> I'll fix the argument names.
> -min_jint is min_jint. So there's no way to handle a min_jint (or min_jlong) scale above. How else would you handle it?

I pushed a commit that addresses both comments.

-------------

PR: https://git.openjdk.java.net/jdk/pull/2045


More information about the hotspot-compiler-dev mailing list