RFR: 8291600: [vectorapi] vector cast op check is not always needed for vector mask cast [v3]
Quan Anh Mai
duke at openjdk.org
Thu Aug 25 07:37:55 UTC 2022
On Thu, 25 Aug 2022 07:03:05 GMT, Xiaohong Gong <xgong at openjdk.org> wrote:
>> src/hotspot/cpu/x86/c2_MacroAssembler_x86.hpp line 337:
>>
>>> 335: void vector_mask_cast(XMMRegister dst, XMMRegister src, BasicType dst_bt, BasicType src_bt, int vlen);
>>> 336:
>>> 337: void vector_mask_cast_with_tmp(XMMRegister dst, XMMRegister src, XMMRegister xtmp1,
>>
>> I would prefer the name as `vector_mask_cast`.
>
> Will fix this in a separate patch. Thanks!
I think it's fine, I see we don't name methods in `C2_MacroAssembler` with the same name, except when it is the addessliteral version that would likely to emit the same thing.
-------------
PR: https://git.openjdk.org/jdk/pull/9737
More information about the hotspot-compiler-dev
mailing list