RFR: 8298809: Clean up vm/compiler/InterfaceCalls JMH

Vladimir Kozlov kvn at openjdk.org
Thu Dec 15 20:36:04 UTC 2022


On Thu, 15 Dec 2022 16:05:49 GMT, Eric Caspole <ecaspole at openjdk.org> wrote:

> I removed some confusing less effective cases and modified and renamed some to cover what seem like the most useful cases with 1+ types and 1+ interfaces implemented in those types. Here is an example run:
> 
> Benchmark                        Mode  Cnt  Score   Error  Units
> InterfaceCalls.test1stInt2Types  avgt   12  2.196 ± 0.022  ns/op
> InterfaceCalls.test1stInt3Types  avgt   12  8.259 ± 0.045  ns/op
> InterfaceCalls.test1stInt5Types  avgt   12  8.279 ± 0.024  ns/op
> InterfaceCalls.test2ndInt2Types  avgt   12  2.467 ± 0.023  ns/op
> InterfaceCalls.test2ndInt3Types  avgt   12  9.287 ± 0.032  ns/op
> InterfaceCalls.test2ndInt5Types  avgt   12  9.343 ± 0.027  ns/op
> InterfaceCalls.testMonomorphic   avgt   12  1.440 ± 0.031  ns/op

To be consistent I think we should rename interfaces and their methods:


    interface FirstInterface {
        public int getIntFirst();
     }

     interface SecondInterface {
         public int getIntSecond();
     }

-------------

Changes requested by kvn (Reviewer).

PR: https://git.openjdk.org/jdk/pull/11696


More information about the hotspot-compiler-dev mailing list