RFR: 8277926: [aarch64] Address constructors are lacking initialisation.
Patric Hedlin
phedlin at openjdk.java.net
Mon Jan 24 09:59:29 UTC 2022
Please review changes to secure proper initialisation in Address constructors.
Changes include (with additional clean-up):
Renamed '**literal**' to '**addr_literal**'.
Renamed '**_ext**' to '**_extend**'.
Renamed Address::mode enum to Address::addr_mode.
Renamed Address::getMode() to Address::mode().
Reorder _mode.
Initialise '**_extend**' to **lsl(0)**.
Initialise '**_target**' to **nullptr**.
Added preconditions to constructors.
Added preconditions to check 'target' address.
Removed '**pcrel**' addressing mode (unused).
Removed direct attribute use in Address.
Minor clean-up to RuntimeAddress use.
---8<---
Testing: tier1-6 (Linux), tier1-3 (MacOSX)
-------------
Commit messages:
- Cleanup: Renamed Address::mode enum to Address::addr_mode.
- Cleanup/simplify Address constructors.
- Reorder _mode. Rename _ext to _extend. Init _target to nullptr.
- More preconditions. Removed direct attribute use in Address.
- Removed 'pcrel' addressing mode (unused).
- Added a few preconditions to check 'target' address.
- Rename literal to addr_literal.
- Minor cleanup to RuntimeAddress use.
- 8277926: [aarch64] Address constructors are lacking initialisation.
Changes: https://git.openjdk.java.net/jdk/pull/7191/files
Webrev: https://webrevs.openjdk.java.net/?repo=jdk&pr=7191&range=00
Issue: https://bugs.openjdk.java.net/browse/JDK-8277926
Stats: 154 lines in 7 files changed: 36 ins; 12 del; 106 mod
Patch: https://git.openjdk.java.net/jdk/pull/7191.diff
Fetch: git fetch https://git.openjdk.java.net/jdk pull/7191/head:pull/7191
PR: https://git.openjdk.java.net/jdk/pull/7191
More information about the hotspot-compiler-dev
mailing list