RFR: 8282204: Use lea instructions for arithmetic operations on x86_64 [v7]

Quan Anh Mai duke at openjdk.java.net
Thu Mar 3 00:30:55 UTC 2022


On Wed, 2 Mar 2022 14:30:21 GMT, Jie Fu <jiefu at openjdk.org> wrote:

>> Quan Anh Mai has updated the pull request incrementally with one additional commit since the last revision:
>> 
>>   remove irrelevent changes
>
> src/hotspot/cpu/x86/x86_64.ad line 3523:
> 
>> 3521:   match(RegI);
>> 3522:   match(rRegI);
>> 3523:   match(rax_RegI);
> 
> Why explicitly match rax, rbx, ..., rdi here?

Tbh I'm not sure but the other operands seem to do the same thing

> src/hotspot/cpu/x86/x86_64.ad line 7511:
> 
>> 7509: %}
>> 7510: 
>> 7511: instruct leaI_rReg_rReg_immI(rRegI dst, rRegI src1, rRegI src2, immI disp)
> 
> Please rename src1/src2 with base/index.

Done

> src/hotspot/cpu/x86/x86_64.ad line 7724:
> 
>> 7722: %}
>> 7723: 
>> 7724: instruct leaL_rReg_rReg_immI2_no_disp(rRegL dst, no_rbp_r13_RegL base, rRegL index, immI2 scale)
> 
> Does it make too much sense to keep both `leaL_rReg_rReg_immI2_no_disp ` and `leaL_rReg_rReg_immI2 ` for real programs?
> 
> The more instruct rules in the AD file, the bigger of the libjvm.so would be.
> I would suggest removing `leaL_rReg_rReg_immI2 `.

I agree

-------------

PR: https://git.openjdk.java.net/jdk/pull/7560


More information about the hotspot-compiler-dev mailing list