RFR: 8281266: [JVMCI] MetaUtil.toInternalName() doesn't handle hidden classes correctly
Severin Gehwolf
sgehwolf at openjdk.java.net
Mon Mar 7 09:59:56 UTC 2022
On Fri, 4 Feb 2022 12:01:46 GMT, Foivos <duke at openjdk.java.net> wrote:
> https://github.com/openjdk/jdk/commit/7cc137105928ec109a29d9315565f7f49af3cf2b introduced hidden classes with internal names like `com/example/Foo.1234` that get changed to `com.example.Foo/1234` by `Class.getName()` which are not properly handled by `MetaUtil`'s `toInternalName` and `internalNameToJava`
>
> This PR fixes this along with the corresponding test that used to work on the assumption that the internal class names didn't contain the `.` character and that java class names didn't contain the `/` character except for lambdas (which are now treated as hidden classes as well), an assumption that no longer holds.
This looks fine to me. Perhaps @dougxc or @tkrodriguez want to have a look at this too?
src/jdk.internal.vm.ci/share/classes/jdk.vm.ci.meta/src/jdk/vm/ci/meta/MetaUtil.java line 127:
> 125: switch (name.charAt(0)) {
> 126: case 'L': {
> 127: String result = replacePackageAndHiddenSeparators(name.substring(1, name.length() - 1), '/', '.');
Consider extracting constants `/` (as `PACKAGE_SEP_INTERNAL` perhaps) and `.` (as `HIDDEN_SEP_INTERNAL`). You could then also create the inversely defined constants `PACKAGE_SEP_JAVA` and `HIDDEN_SEP_JAVA`. It would make the code slightly easier to read.
-------------
Marked as reviewed by sgehwolf (Reviewer).
PR: https://git.openjdk.java.net/jdk/pull/7346
More information about the hotspot-compiler-dev
mailing list