RFR: 8293170: Improve encoding of the debuginfo nmethod section [v11]
Boris Ulasevich
bulasevich at openjdk.org
Wed Nov 16 07:54:30 UTC 2022
On Tue, 15 Nov 2022 22:03:34 GMT, Evgeny Astigeevich <eastigeevich at openjdk.org> wrote:
>> Boris Ulasevich has updated the pull request incrementally with one additional commit since the last revision:
>>
>> cleanup, rename
>
> src/hotspot/share/code/compressedStream.hpp line 127:
>
>> 125: }
>> 126:
>> 127: u_char* buffer() const { return _buffer; }
>
> The function changes access to `_buffer` from `protected` to `public`.
> Should it be:
>
> const u_char* buffer() const;
Please check my change.
- I move _buffer from CompressedSparseData to CompressedSparseDataReadStream and CompressedSparseDataWriteStream - the first one is constant.
- I update debugInfoRec.cpp, nmethod.cpp, nmethod.hpp. On the one hand, I would like to avoid a lot of file chaining. On the other hand, the const modifier adds readability.
Is that what you meant?
-------------
PR: https://git.openjdk.org/jdk/pull/10025
More information about the hotspot-compiler-dev
mailing list