RFR: 8286302: Port JEP 425 to PPC64 [v7]
Richard Reingruber
rrich at openjdk.org
Tue Nov 22 17:33:05 UTC 2022
On Tue, 22 Nov 2022 01:57:54 GMT, Leonid Mesnik <lmesnik at openjdk.org> wrote:
>> Richard Reingruber has updated the pull request incrementally with one additional commit since the last revision:
>>
>> Cleanup BasicExp test
>
> test/jdk/jdk/internal/vm/Continuation/BasicExp.java line 369:
>
>> 367: }
>> 368:
>> 369: public void log_dontjit() {
>
> Please use camelCase for all functions.
I'd rather not because where I do not already use camelCase it is because I added a name prefix/suffix to the method that is used to control compilation and inlining. IMHO readability is better if these technical name extensions are separated by an underscore from the method name.
Let's see what others say.
> test/jdk/jdk/internal/vm/Continuation/BasicExp.java line 484:
>
>> 482: log_dontjit("Exc: " + e);
>> 483: }
>> 484: if (callSystemGC) System.gc();
>
> It would be better to call WB.fullGC() not System,gc() to ensure that GC is called.
Good point! Actually WB.youngGC() is sufficient and reduces the runtime significantly.
> test/jdk/jdk/internal/vm/Continuation/BasicExp.java line 504:
>
>> 502: }
>> 503:
>> 504: static final long i1=1; static final long i2=2; static final long i3=3;
>
> Please fix identation.
Done
> test/jdk/jdk/internal/vm/Continuation/BasicExp.java line 729:
>
>> 727: log_dontjit("Continuation running on thread " + Thread.currentThread());
>> 728: long res = ord101_recurse_dontinline(0, i1, i2, i3, i4, i5, i6, i7, i8, i9, i10, i11);
>> 729: if (res != i1+i2+i3+i4+i5+i6+i7+i8+i9+i10+i11) {
>
> Please fix the indentation. There are several places were 'i1+i2' should be fixed to 'i1 + i2 '.
Done
-------------
PR: https://git.openjdk.org/jdk/pull/10961
More information about the hotspot-compiler-dev
mailing list