RFR: 8293170: Improve encoding of the debuginfo nmethod section [v6]
Evgeny Astigeevich
eastigeevich at openjdk.org
Tue Oct 25 09:42:59 UTC 2022
On Thu, 20 Oct 2022 12:04:32 GMT, Boris Ulasevich <bulasevich at openjdk.org> wrote:
>> The nmethod "scopes data" section is 10% of the size of nmethod. Now the data is compressed using the Pack200 algorithm, which is good for encoding small integers (LineNumberTable, etc). Using the fact that half of the data in the partition contains zeros, I reduce its size by another 30%.
>>
>> Testing: jtreg hotspot&jdk, Renaissance benchmarks
>
> Boris Ulasevich has updated the pull request incrementally with one additional commit since the last revision:
>
> minor renaming. adding encoding examples table
src/hotspot/share/code/compressedStream.cpp line 179:
> 177: }
> 178:
> 179: void CompressedSparseDataWriteStream::write_zero() {
We can rewrite the function not to use `_curr_byte`. We work directly on `_buffer` and rename `_bit_pos` into `_used_bits`:
_buffer[_position] >>= 1;
if (++_used_bits == 8) {
_position += 1;
_used_bits = 0;
}
-------------
PR: https://git.openjdk.org/jdk/pull/10025
More information about the hotspot-compiler-dev
mailing list