RFR: 8309130: x86_64 AVX512 intrinsics for Arrays.sort methods (int, long, float and double arrays) [v6]

Srinivas Vamsi Parasa duke at openjdk.org
Fri Aug 4 18:30:37 UTC 2023


On Tue, 6 Jun 2023 19:18:40 GMT, Jatin Bhateja <jbhateja at openjdk.org> wrote:

>> Srinivas Vamsi Parasa has updated the pull request incrementally with one additional commit since the last revision:
>> 
>>   fix license in one file
>
> src/java.base/share/classes/java/util/Arrays.java line 82:
> 
>> 80: 
>> 81:     @IntrinsicCandidate
>> 82:     private static void arraySort(int[] array, int fromIndex, int toIndex) {
> 
> A minor styling comment: We can use same all small caps naming convention as used for System.arraycopy.

Thanks for the suggestion. For now, we will stick with arraySort as this is a private method.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/14227#discussion_r1284726224


More information about the hotspot-compiler-dev mailing list