RFR: JDK-8300808: Accelerate Base64 on x86 for AVX2 [v7]
Claes Redestad
redestad at openjdk.org
Thu Feb 2 00:37:29 UTC 2023
On Wed, 1 Feb 2023 20:59:24 GMT, Scott Gibbons <duke at openjdk.org> wrote:
>> src/hotspot/cpu/x86/stubGenerator_x86_64.cpp line 2202:
>>
>>> 2200: }
>>> 2201:
>>> 2202: address StubGenerator::base64_AVX2_decode_URL_tables_addr() {
>>
>> Shouldn't this be `decode_lut_tables`? As it's used for URL and non-URL decoding alike.
>
> These tables are used for both URL and non-URL based on the parameter, and they are only two of the three lut tables used (the other is in `base64_AVX2_decode_tables_addr` ). Both names are essentially incorrect. Does the name really matter that much? It's the same as `base64_AVX2_decode_tables_addr` with the addition of URL tables.
Names are important, but always hard to get right. At the very least they need to be correct. Maybe call it something like `..parameterized_decode_tables..` and the other `..shared_decode_tables..`?
-------------
PR: https://git.openjdk.org/jdk/pull/12126
More information about the hotspot-compiler-dev
mailing list