RFR: JDK-8287061: Support for rematerializing scalar replaced objects participating in allocation merges [v18]
Cesar Soares Lucas
cslucas at openjdk.org
Fri Jun 23 15:03:19 UTC 2023
On Wed, 14 Jun 2023 20:19:58 GMT, Vladimir Ivanov <vlivanov at openjdk.org> wrote:
>> Cesar Soares Lucas has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains 19 commits:
>>
>> - Merge branch 'openjdk:master' into rematerialization-of-merges
>> - Rome minor refactorings.
>> - Merge remote-tracking branch 'origin/master' into rematerialization-of-merges
>> Catching up with master.
>> - Address PR review 6: debug format output & some refactoring.
>> - Catching up with master branch.
>>
>> Merge remote-tracking branch 'origin/master' into rematerialization-of-merges
>> - Address PR review 6: refactoring around rematerialization & improve test cases.
>> - Address PR review 5: refactor on rematerialization & add tests.
>> - Merge remote-tracking branch 'origin/master' into rematerialization-of-merges
>> - Address part of PR review 4 & fix a bug setting only_candidate
>> - Catching up with master
>>
>> Merge remote-tracking branch 'origin/master' into rematerialization-of-merges
>> - ... and 9 more: https://git.openjdk.org/jdk/compare/57b82512...939dcffe
>
> src/hotspot/share/opto/c2_globals.hpp line 473:
>
>> 471: " register allocation.") \
>> 472: \
>> 473: product(bool, ReduceAllocationMerges, true, \
>
> I suggest to turn the flag into diagnostic one. There are much stricter requirements for product flags, so better to avoid introducing new ones.
@iwanowww - I'm confused by what a "Diagnostic" flag is. According to [this documentation](https://wiki.openjdk.org/display/HotSpot/Hotspot+Command-line+Flags%3A+Kinds%2C+Lifecycle+and+the+CSR+Process) "Diagnostic flags are not meant for VM tuning or for product modes. They are to be used for VM quality assurance or field diagnosis of VM bugs [...]" I believe the patch I'm proposing is a VM tuning optimization, so should it really be a diagnostic flag? Besides, I think we'll try _at a later moment_ to make this a product flag. Do you think an experimental flag is more appropriate? Thank you.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/12897#discussion_r1239928841
More information about the hotspot-compiler-dev
mailing list