RFR: 8306966: RISC-V: Support vector cast node for Vector API [v6]

Gui Cao gcao at openjdk.org
Thu May 4 16:16:06 UTC 2023


On Thu, 4 May 2023 12:31:03 GMT, Feilong Jiang <fjiang at openjdk.org> wrote:

>> Gui Cao has updated the pull request incrementally with one additional commit since the last revision:
>> 
>>   Fix round mode and optimize widen/narrow vcast
>
> src/hotspot/cpu/riscv/c2_MacroAssembler_riscv.cpp line 1673:
> 
>> 1671: }
>> 1672: 
>> 1673: void C2_MacroAssembler::rvv_reduce_integral(Register dst, VectorRegister tmp,
> 
> Could you please rename this to `reduce_integral_v`, we already got `xxxxx_v` naming style.
> Suggestion:
> 
> void C2_MacroAssembler::reduce_integral_v(Register dst, VectorRegister tmp,

Fixed.

> src/hotspot/cpu/riscv/c2_MacroAssembler_riscv.cpp line 1711:
> 
>> 1709: // Set vl and vtype for full and partial vector operations.
>> 1710: // (vma = mu, vta = tu, vill = false)
>> 1711: void C2_MacroAssembler::rvv_vsetvli(BasicType bt, int vector_length, LMUL vlmul, Register tmp) {
> 
> Same here:
> Suggestion:
> 
> void C2_MacroAssembler::vsetvli_v(BasicType bt, int vector_length, LMUL vlmul, Register tmp) {

Fixed.

> src/hotspot/cpu/riscv/c2_MacroAssembler_riscv.cpp line 1784:
> 
>> 1782: }
>> 1783: 
>> 1784: void C2_MacroAssembler::vector_integer_extend(VectorRegister dst, BasicType dst_bt, int vector_length,
> 
> Suggestion:
> 
> void C2_MacroAssembler::integer_extend_v(VectorRegister dst, BasicType dst_bt, int vector_length,

Thanks for the review. Fixed as suggested.

> src/hotspot/cpu/riscv/c2_MacroAssembler_riscv.cpp line 1822:
> 
>> 1820: // Vector narrow from src to dst with specified element sizes.
>> 1821: // High part of dst vector will be filled with zero.
>> 1822: void C2_MacroAssembler::vector_integer_narrow(VectorRegister dst, BasicType dst_bt, int vector_length,
> 
> Suggestion:
> 
> void C2_MacroAssembler::integer_narrow_v(VectorRegister dst, BasicType dst_bt, int vector_length,

Fixed.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/13684#discussion_r1185223652
PR Review Comment: https://git.openjdk.org/jdk/pull/13684#discussion_r1185223073
PR Review Comment: https://git.openjdk.org/jdk/pull/13684#discussion_r1185222520
PR Review Comment: https://git.openjdk.org/jdk/pull/13684#discussion_r1185222820


More information about the hotspot-compiler-dev mailing list