RFR: 8302652: [SuperWord] Reduction should happen after loop, when possible [v9]
Emanuel Peter
epeter at openjdk.org
Fri May 19 05:00:58 UTC 2023
On Wed, 17 May 2023 18:52:43 GMT, Jatin Bhateja <jbhateja at openjdk.org> wrote:
>> Emanuel Peter has updated the pull request incrementally with one additional commit since the last revision:
>>
>> added missing float/double cases to VectorNode::scalar_opcode
>
> src/hotspot/share/opto/loopopts.cpp line 4192:
>
>> 4190:
>> 4191: // Convert opcode from vector-reduction -> scalar -> normal-vector-op
>> 4192: const int sopc = VectorNode::scalar_opcode(last_ur->Opcode(), bt);
>
> Other changes looks good to me, can you rename _VectorNode::scalar_opcode_ to _ReductionNode::scalar_opcode_
> , also move out vector opcode cases into a separate vector-to-scalar mapping routine if needed.
Is it not better to have `VectorNode::scalar_opcode`? It is more general - maybe it is useful in the future.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/13056#discussion_r1198544502
More information about the hotspot-compiler-dev
mailing list