RFR: 8308583: SIGSEGV in GraphKit::gen_checkcast [v2]

Roland Westrelin roland at openjdk.org
Thu May 25 16:06:43 UTC 2023


On Thu, 25 May 2023 15:48:39 GMT, Vladimir Kozlov <kvn at openjdk.org> wrote:

>> Roland Westrelin has updated the pull request incrementally with one additional commit since the last revision:
>> 
>>   review
>
> src/hotspot/share/opto/graphKit.cpp line 3525:
> 
>> 3523:   if (!StressReflectiveCode && inst_klass != nullptr) {
>> 3524:     bool    xklass = inst_klass->klass_is_exact();
>> 3525:     if (xklass || (inst_klass->isa_aryklassptr() && inst_klass->is_aryklassptr()->elem() != Type::BOTTOM)) {
> 
> Can you rename `inst_klass` to `klass_ptr` because it is general klass. It is weird to see a check like `inst_klass->isa_aryklassptr()`.

I pushed a new commit that includes the rename.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/14123#discussion_r1205731094


More information about the hotspot-compiler-dev mailing list