RFR: 8316592: RISC-V: implement poly1305 intrinsic [v13]

ArsenyBochkarev duke at openjdk.org
Tue Nov 21 06:43:43 UTC 2023


On Tue, 21 Nov 2023 00:22:21 GMT, Fei Yang <fyang at openjdk.org> wrote:

>> ArsenyBochkarev has updated the pull request incrementally with one additional commit since the last revision:
>> 
>>   Rename bits* -> right_*_bits & make regalloc more readable
>
> src/hotspot/cpu/riscv/stubGenerator_riscv.cpp line 2712:
> 
>> 2710:     __ addi(trailing_zeros, trailing_zeros, haystack_isL ? 7 : 15);
>> 2711:     __ slli(needle_len, needle_len, BitsPerByte * wordSize / 2);
>> 2712:     __ orr(haystack_len, haystack_len, needle_len); // restore needle_len(3right_2_bits)
> 
> Ah, this looks strange. Why replace `32bits` with `3right_2_bits` in your last commit?

Oh, this happened by accident, thanks for pointing out!

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/16417#discussion_r1400086443


More information about the hotspot-compiler-dev mailing list