RFR: 8335257: Refactor code to create Initialized Assertion Predicates into separate class [v2]
Christian Hagedorn
chagedorn at openjdk.org
Fri Jul 5 08:56:48 UTC 2024
On Fri, 5 Jul 2024 08:53:35 GMT, Christian Hagedorn <chagedorn at openjdk.org> wrote:
>> This is the next patch for Assertion Predicates. It refactors the code to create an Initialized Assertion Predicate. Changes include:
>>
>> - `clone_assertion_predicate_and_initialize()` currently does two things: Cloning a Template Assertion Predicate and creating an Initailized Assertion Predicate. I've split this method into two methods `clone_template_assertion_predicate()` and `create_initialized_assertion_predicate()`:
>> - `clone_template_assertion_predicate()`: Now only clones the template. I have not cleaned the code up further because I will soon replace the `If` node with a dedicated `TemplateAssertionPredicateNode`.
>> - `create_initialized_assertion_predicate()`: I refactored the code for Initialized Assertion Predicate into a separate class `InitializedAssertionPredicate` which creates the complete Initialized Assertion Predicate `If` with a `HaltNode`. I could get rid of some of the arguments because they can be fetched inside the new class methods.
>> - Moved `assertion_predicate_has_loop_opaque_node()` asserts to both methods.
>> - Renamed `AssertionPredicateType::Init_value` -> `AssertionPredicateType::InitValue` (same for last value).
>>
>> Thanks,
>> Christian
>
> Christian Hagedorn has updated the pull request with a new target base due to a merge or a rebase. The incremental webrev excludes the unrelated changes brought in by the merge/rebase. The pull request contains three additional commits since the last revision:
>
> - review Emanuel
> - Merge branch 'refs/heads/master' into JDK-8335257
> - 8335257: Refactor code to create Initialized Assertion Predicates into separate class
Thanks for your review! I've pushed an update and responded to your suggestions.
src/hotspot/share/opto/predicates.cpp line 450:
> 448: }
> 449:
> 450: void InitializedAssertionPredicate::create_fail_path(IfNode* if_node, IdealLoopTree* loop) {
Renamed this to fail path which matches "success path".
-------------
PR Review: https://git.openjdk.org/jdk/pull/19940#pullrequestreview-2159134035
PR Review Comment: https://git.openjdk.org/jdk/pull/19940#discussion_r1666535369
More information about the hotspot-compiler-dev
mailing list