RFR: 8333684: C2 SuperWord: multiple smaller refactorings in preparation for JDK-8332163
Emanuel Peter
epeter at openjdk.org
Wed Jun 12 12:07:17 UTC 2024
On Wed, 12 Jun 2024 10:58:14 GMT, Christian Hagedorn <chagedorn at openjdk.org> wrote:
>> src/hotspot/share/opto/superword.cpp line 1779:
>>
>>> 1777: retValue = UseVectorCmov;
>>> 1778: } else if (VectorNode::is_scalar_op_that_returns_int_but_vector_op_returns_long(opc)) {
>>> 1779: // Requires extra vector long -> int conversion.
>>
>> Note: moved comments to method definition. Chose better name.
>
> The name is quite verbose. How about keeping it as suggested in this comment, something like `needs_vector_long_to_int_conversion()`?
But that is misleading. This is about `scalar` ops, and they do not need any `vector_long_to_int_conversion`. It is the corresponding `vector` op that needs that conversion. I would rather have a more verbose but descriptive name. Otherwise we can also keep the old name, just because it means no change. But that would be sad too.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/19573#discussion_r1636341715
More information about the hotspot-compiler-dev
mailing list