RFR: 8334060: Implementation of Late Barrier Expansion for G1
Roberto Castañeda Lozano
rcastanedalo at openjdk.org
Wed Jun 19 08:59:10 UTC 2024
On Wed, 19 Jun 2024 08:42:26 GMT, Albert Mingkun Yang <ayang at openjdk.org> wrote:
>> Is [this](https://github.com/robcasloz/jdk/compare/JDK-8334060-g1-late-barrier-expansion...robcasloz:jdk:JDK-8334060-g1-late-barrier-expansion-alberts-barriers-suggestion) what you had in mind? I don't have a strong opinion, but if you think the change improves readability I am happy to merge it.
>
> Yes.
>
> Two nits: add `can_` to those two bools and unpack the final return expr, sth like:
>
>
> int barriers = 0;
>
> if (!can_remove_pre...) {
> barriers |= pre;
> }
> if (!can_remove_post...) {
> barriers |= post;
> }
>
> return barriers;
Thanks, I will do some testing before merging.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/19746#discussion_r1645729241
More information about the hotspot-compiler-dev
mailing list