RFR: 8320649: C2: Optimize scoped values [v15]
Roland Westrelin
roland at openjdk.org
Thu May 2 07:18:05 UTC 2024
On Thu, 18 Apr 2024 11:45:07 GMT, Emanuel Peter <epeter at openjdk.org> wrote:
>> src/hotspot/share/opto/loopopts.cpp line 4010:
>>
>>> 4008: peel.remove(hits_in_cache->_idx);
>>> 4009: not_peel.set(hits_in_cache->_idx);
>>> 4010: peel_list.remove(i);
>>
>> Looks like duplicated code from the call-site. A refactoring may help.
>
> I think you could combine the code with the case:
> `if (n->in(0) == nullptr && !n->is_Load() && !n->is_CMove()) {`
> And then you would have this code here, as well as the `TracePartialPeeling` code shared for both.
I moved that code to a helper method so it's shared.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/16966#discussion_r1587169416
More information about the hotspot-compiler-dev
mailing list