RFR: 8343214: Fix encoding errors in APX New Data Destination Instructions Support [v3]
Jatin Bhateja
jbhateja at openjdk.org
Fri Nov 1 01:42:31 UTC 2024
On Wed, 30 Oct 2024 22:11:31 GMT, Srinivas Vamsi Parasa <sparasa at openjdk.org> wrote:
>> src/hotspot/cpu/x86/assembler_x86.cpp line 2632:
>>
>>> 2630: InstructionAttr attributes(AVX_128bit, /* vex_w */ false, /* legacy_mode */ false, /* no_mask_reg */ true, /* uses_vl */ false);
>>> 2631: attributes.set_address_attributes(/* tuple_type */ EVEX_NOSCALE, /* input_size_in_bits */ EVEX_32bit);
>>> 2632: evex_prefix_nf(src, 0, dst->encoding(), VEX_SIMD_NONE, VEX_OPCODE_0F_3C, &attributes, no_flags);
>>
>> Could you also replace VEX_OPCODE_OF_3C with the standard naming convention of VEX_OPCODE_MAP4?
>> I added /*MAP4*/ in the comments after the prefix for the setzuCC instruction, but it's better to make this change consistently in all places.
>
> Hi Jatin,
>
> If I understand correctly, are you suggesting that I add a comment in the front like `/* MAP4 */VEX_OPCODE_0F_3C` for all occurrences of VEX_OPCODE_OF_3C in this PR?
I would prefer directly using VEX_OPCODE_MAP4 as its a standard naming convention used by [APX specifications](https://cdrdv2.intel.com/v1/dl/getContent/784266)
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/21770#discussion_r1825338330
More information about the hotspot-compiler-dev
mailing list